Welcome, Guest
(Login | My Resources)

Important Notice About the Heartbleed Virus

Publication Date: 4/11/2014 11:22:56 AM

In response to the threat of the Heartbleed Virus, security experts recommend checking servers that host public facing websites to determine their use of OpenSSL. If the use of OpenSSL is confirmed, a patch to the latest version of OpenSSL should be made as soon as possible.

PSST does not use OpenSSL, so we can confirm that we are not susceptible to this threat.

Our eStub product is hosted on our clients’ web servers, which use Microsoft IIS and usually are not configured to use OpenSSL.  As a precaution, however, PSST recommends that eStub clients ask their technology departments to contact their SSL Certificate vendors to assess vulnerability to the Heartbleed Virus.